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ABSTRACT

ImageCatatlog is an image cataloging program for the Macintosh™.  
ImageCatatlog does for computer images what a contact sheet does for 
photography—it shows a catalog of dozens of images arranged on the same page.  
ImageCatatlog will take a collection of image files and organize them as high-
quality reduced image cells in a single window.  Double-clicking on a cell opens the 
corresponding file.  Cells can be set to either display the image locally or launch it 
with a different application.  ImageCatatlog knows MacPaint, PICT,  JPEG, JFIF, TIFF, 
and GIF formats, though with a little work any image format can be used.  Requires 
Color QuickDraw and System 7.  QuickTime™ preferred, but not required.

Quick Start…
• Drag and drop some image files onto ImageCatatlog.
• Sit back and watch the catalog build itself.
OR
• Follow one of the examples at the end of this document.

Business
Copyright

ImageCatatlog is © Copyright 1990-1993, Tom Bereiter. All rights reserved.  
ImageCatatlog  is not public domain, however, it may be redistributed free of charge, 
subject to the following conditions: 1) the software and documentation must be distributed 
together, without modification.  2) No part of this copyright notice may be omitted or 
modified.  3) ImageCatatlog may not be sold or offered for sale, or "included" with another 
product offered for sale, except with the express written permission of the author.  4) 
Companies that profit from the distribution of public domain and shareware software, such 
as EDUCORP, BudgetBytes, and SOMAK, are EXPRESSLY PROHIBITED from distributing 
ImageCatatlog.

Disclaimer
The author makes no warranties, express or implied, including without limitation the implied warranties of merchantability and 
fitness for a particular purpose, regarding ImageCatatlog.   The author does not warrant, guarantee or make any representations 
regarding the use or the results of the use of ImageCatatlog in terms of its correctness, accuracy, reliability, currentness or 
otherwise.  The entire risk as to the results and performance of ImageCatatlog is assumed by you.
  In no event will the author be liable to you for any consequential, incidental or indirect damages (including damages for loss of 
business profits, business interruption, loss of business information, and the like) arising out of the use or inability to use 
ImageCatatlog even if the author has been advised of the possibility of such damages.
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Introduction
ImageCatatlog grew out of the need to once-and-for-all-organize-that-clip-art-collection.  On a 13-
inch color monitor a single ImageCatatlog catalog will display 32 MacPaint pictures, nicely 
reduced, and in greyscale so they are recognizable.  Double-clicking on one of the reduced pictures 
opens a new full-size window of the picture.  The picture can be copied to the clipboard for pasting 
into other applications.

ImageCatatlog is designed along the tool concept: it does a small number of things well and 
doesn't try to do too much.  ImageCatatlog is not an image converter,  it is not an image 
processing package, nor  is it a paint program.  ImageCatatlog should be thought of as a tool 
which works in conjunction with other image programs.

Possible uses:
• the aforementioned clip art selector.
• Draw/CAD  program browser.  Most drawing and CAD  programs can frazzle nerves with the 

amount of time they take to display complicated drawings, especially when all you are doing is
hunting for a specific picture.

• Pictorial side of a photograph database.

Windows
There are three types of windows: Image windows, Catalog windows, and Text Listing windows.  
ImageCatatlog windows make full use of the 256 colors available; this means that when a 
ImageCatatlog window is open it will have priority over the available colors, frequently making the
desktop colors or colors in other windows appear wrong.
Image Window
An image window is a standard scrollable view of an image.  An image window is created when an 
image file is opened from the main menu or when a cell in a catalog window is opened.

• The contents of an image window  may be copied to the clipboard.

Catalog Window
A catalog window is a window divided into cells where each cell contains a reduced view of a larger 
image.  This multi-cell window acts as a catalog for images.  A typical window will show 30-40 
images at the same time.  By default ImageCatatlog uses a high quality averaging technique to 
reduce the images, which maintains most of the image detail.  For many low-resolution images, this
technique produces reductions superior in appearance to the original.  The title of a catalog window
is always bracketed by '◊' characters, to distinguish it from image windows.

Each cell is associated with a file on disk.  Each cell is divided into two parts: the top part contains 
the reduced image; the bottom part shows the name of the disk file and related image information.

• Double-clicking in a cell will open the disk file associated with the cell.  If the cell specifies 
"Open with Finder", then the Finder will be used to launch the disk file as though you had 
double-clicked on it from the Finder.

• Double-clicking on the title of an image will open the title-edit dialog.
• Swap cells by dragging one onto the other
• Insert cell by dragging onto grid line, or by Shift-dragging to cell you wish to place it after.
• adjust position of cell in row by dragging to new position (variable spacing only).
• A cell can be removed by single-clicking on it, then hitting the delete-key or selecting 

Clear from the Edit menu.
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• A catalog can be saved either compressed or uncompressed.  Compressing a catalog saves

disk space, but it takes longer to save and open.  Compression is set from the Preferences 
dialog of the Edit menu.

Text Listing window
A Text Listing window is an alternate way to view catalog windows.  A catalog window must 
currently be open before the List as text command may be issued.  The listing has one line per 
cell that shows the attributes of the file associated with the cell.

• Double-clicking on a line opens the file, exactly the same as double-clicking on the cell in 
the catalog window.

• Copying a Text Listing using the Edit menu Copy command will copy all the text in the Text
Listing to the clipboard.  By default the text is copied separated by spaces.  Hold down the 
Shift-key to copy the text as tab-delimited fields.

Using ImageCatatlog
System Requirements
ImageCatatlog requires system 7.0 or later, and at least  two megabytes of RAM.
Internal Image Viewer
ImageCatatlog can read images of MacPaint, PICT,  JFIF, JPEG, TIFF, and GIF formats. These 
formats cover most of the standard formats likely to be found on a Mac.  ImageCatatlog has an 
internal image viewer which will read and display entire full-size images.
Creating a new catalog
Creating a new catalog from a folder of image files is a largely automatic process:

1) create the catalog with the New Catalog… command.

2) fill the catalog.  This can be done in one of three ways:
a) drag-and-drop files onto ImageCatatlog  using the Finder.
b) use the multi-file Open dialog
c) open a file in the Internal Image Viewer, then issue the Add image command.

Opening a cell with a different application
When a catalog is created, the Custom sub-dialog of the New Catalog dialog, can be used to specify
that all cells should be opened with the Finder rather than the internal image view.  This setting 
may be changed on a per-cell basis from the title-edit dialog accessed by double-clicking on the 
title of a cell.  When a cell specifies "Open with Finder", the Finder will be used to launch the disk 
file as though you had double-clicked on it from the Finder.  If the Finder does not know how to open
the file associated with the cell the Finder will display an error dialog.

Reading image types unknown to ImageCatatlog
ImageCatatlog can be used to catalog images of any type.   Copy an image from your application 
to the clipboard as a PICT then paste it into ImageCatatlog.  After pasting you are asked to attach 
a file.  Once a file is attached it is as though the file itself had been read.

Even if your application cannot paste PICTs to the clipboard there is always some other way.  There 
are many suites of conversion programs (e.g. PhotoShop™ on the Mac or pbmplus under UNIX™).  
As a last resort, for the extremely dedicated,  you could do a screen dump while your file is open to 
get a MacPaint file.
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Prefs file
ImageCatatlog creates a file called ImageCatatlog Prefs in the preferences directory.  This file 
saves the preferences between invocations of ImageCatatlog.

Dialogs
New Catalog/Reconfigure Catalog
Used to configure a new catalog or to reconfigure an existing catalog.  Options are:

Cell Horiz & Vert
size of catalog image cells in pixels

Window Horiz & Vert
number of rows & columns of cells

8-bit - 32-bit RGB
select between catalog depths

Monochrome
catalog is monochrome

Dither
dither images as the are added.  Everything looks better with this set except for narrow-line 
drawings.

Open all images 8-bit
Open deep images as 8-bit (doesn't require as much memory)

Custom
present Custom catalog dialog.

Custom
Used to customize the appearance of a catalog.

Fixed width - Variable width
These select the type of scaling which occurs to fit the image to a cell.  Fixed width makes 
every cell the same size;  the image is scaled so that it fills the cell as fully as possible while 
maintaining the same image proportions.  Variable width uses the specified cell width as a 
maximum width.  Wide images will be scaled to fit within the maximum width.  Narrow 
images will take only as much width as they need when scaled to the height of the cell.  
Variable width generally makes better use of available space.

grid width
specify the width of the cell grid in pixels.

text lines
number of lines of text to display below cell.

Colors
frame - 1-pixel frame around image
grid - grid which divides window into cells
background - everything which isn't one of the other three in this group.
text - text below cell
text background - background behind text

To select a new color, click on the box to the left of the name.  To disable a color item option-
click the box.  A disabled item appears with a dim 'X' in the box.  Only frame, grid, and text 
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background may be disabled.  When text background is disabled the text background is the 
same as main background.

Comment Format
Sets the default format of text beneath an image cell.  Uses a 'mail-merge'-style format 
where special keywords, indicated by angle-brackets, are replaced with image-specific data. 
Other characters are treated as literal strings, except for the combination \n, which is 
treated as a newline character.  Keywords are:

<fname> - file name
<type> - file type (e.g. PICT)
<dims> - image dimensions (e.g. 640 x 480)
<fsize> - file size in bytes
<depth> - image depth in bits

Open with Finder
Sets the default behavior when a cell is double-clicked.  If TRUE, a cell will be opened using 
the finder; if FALSE, a cell will opened using a built-in image window.  The finder opens the 
image just as if you had double-clicked on the image icon in a finder window.

Preferences
Used to select persistent preferences

General:
No startup window 

don't display startup splash screen
Open on best monitor

open windows on deepest, most colorful monitor
Open all images 8-bit

Open all images greater than 8-bit in 8-bit windows (this will lose color information, 
but saves memory).

Open menu item does:
Open image to catalog - (see FILE/Open below)
Open image in window - (see FILE/Open below)

Image windows:
Dither

dither all image windows by default (makes up for color loss if 'Open all images 8-bit' 
is set).

Automatic Start:
Open default catalog

just create a new catalog when program is started by a drag-and-drop operation, 
rather than display dialog.

Catalogs:
Save compressed

enable compression when saving catalogs.  Choose the level compression with "Set 
Compression" button.  JPEG/Normal is recommended.  QuickTime™ must be installed.
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Dither windows

dither catalog windows by default

Menus
File Menu
New

create a new catalog using the New Catalog dialog.
Open, Close

open, close images or catalogs.   The default is to open images into catalog, rather than 
separate window.  This so that drag and drop does the right thing.  Behavior can be changed
in "Preferences" so that default is to open a window.  When opening to a window you will 
always see the standard open dialog, when opening to a catalog you will always see a multi-
file open dialog.

Open to Window 
open image in a separate window.  Changes to "Open to catalog" if behavior is changed in 
"Preferences" (see Open).

Save, Save as… 
For catalogs, saves to disk.

Page Setup…, Print
Print catalog.  Only works with laser writers: for best results select 'Dither' from edit menu 
and from Page Setup unselect 'bitmap smoothing'.

Quit
quit program.

Edit Menu
Undo 

not implemented—always greyed out.
Copy,Cut,Paste

Copy/Paste cell to clipboard.  Pasting an image can be used to import alien images.
Clear

In a catalog window deletes the selected cell.
Dither

Selects dithering during image display, usually improves image appearance.
Preferences…

Presents a dialog for setting user preferences.
Catalog Menu
Add image

adds the currently opened image to the top catalog (top is the top one as shown in the 
Windows menu).  NOTE: If the target catalog is of type Map to monochrome, then, as a side 
effect, the displayed image will be converted to monochrome.  The associated file on disk is 
not changed.

Reconfigure
Redisplays the New Catalog dialog.  Some fields cannot be changed.

List as Text
displays a new window with a scrolling list of textual descriptions of the images in a catalog.

Clean up cells
in a variable-spacing catalog, space cells evenly along row

Sort cells by
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sorts cells in a catalog by either name, type, or file size.

Examples
Example 1 - building a catalog of MacPaint files
This is so easy it's almost intuitive:

1) Locate the folder containing the MacPaint files you wish to catalog.
2) Select New from the File Menu to create a new catalog.
3) Drag-and-drop all your MacPaint files onto ImageCatatlog.

Example 3 - The unknown file type: building a catalog of Cricket Graph™ 
files
This example explains how to build a catalog of images alien to ImageCatatlog, in this case, 
Cricket Graph™ files.  The steps below apply equally well to any program which can copy its images
to the clipboard in PICT format.

1) Create a Scrapbook File of your images
a) Locate the folder(s) containing the files you wish to catalog.
b) Empty the Scrapbook desk accessory.  If you want to save the current scrapbook 

you can do so by renaming the file Scrapbook File in your system folder to 
something else then changing its name back once you are done with this 
exercise.

c) Open the first of your files with Cricket Graph™.
d) Select Copy (or Copy Graph) from the Edit menu.
e) Open the Scrapbook and paste in the graph.
f) Repeat the steps c)-e) until you have all your files in the scrapbook.

2) Copy Scrapbook to Catalog
a) Open ImageCatatlog
b) Select New from the File Menu to create a new catalog.  From the Custom sub-

dialog select "Open with Finder".
c) Open the Scrapbook and Copy your first image to the clipboard
d) from ImageCatatlog paste the image from the clipboard.  You will be asked 

whether you wish to associate the image with a disk file.  Say "yes" then select 
the associated disk file in the standard file dialog.

e) Repeat the steps c)-d) until  all your images have been pasted from the 
scrapbook.

3) Done.
Try it out: double-click on a cell, this will launch Cricket Graph™ which will open the 
file corresponding to the cell.  You will also probably want to throw away your 
Scrapbook File; it will be quite large if you have processed many files.

Bugs
Known bugs are:

• printing does not work on ImageWriters.
• when SuperBoomerang is in use you cannot type capital letters in the save dialog box.

Other bugs, suggestions
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Send email to:  twb@tivoli.com (usenet).
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UNIX is a trademark of AT&T Bell Laboratories.
Macintosh is a trademark of Apple Computer, Inc.
Cricket Graph is copyright Cricket Software.
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